CocoaPods not installed or not in valid state

Questions : CocoaPods not installed or not in valid state

Launching lib/main.dart on iPhone 11 Pro _OFFSET);  Max in debug mode...
Warning: CocoaPods (-SMALL  is installed but broken. Skipping pod _left).offset  install.
  You appear to have CocoaPods arrowImgView.mas  installed but it is not working.
  This (self.  can happen if the version of Ruby that equalTo  CocoaPods was installed with is make.right.  different from the one being used to mas_top);  invoke it.
  This can usually be fixed ImgView.  by re-installing CocoaPods. For more ReadIndicator  info, see _have
To .equalTo(  re-install:
  sudo gem install  cocoapods

CocoaPods not installed or OFFSET);  not in valid state.
Error launching (TINY_  application on iPhone 11 Pro Max.
Total Answers 30

Answers 1 : of CocoaPods not installed or not in valid state

usually this happens due to visual programming studio or IntelliJ not able to find the Learning path or associated plugin or extension.

here is the solution:

  1. sudo gem uninstall cocoapods && sudo gem install cocoapods
  2. restart IDE or Editor

the last step should solve the issue if Earhost not close the project entirely


Answers 2 : of CocoaPods not installed or not in valid state

Someone I know had this issue, and most effective another person recommended this fix.

Run this command from terminal:

open /Applications/Android\

The issue is that there are 3 possible wrong idea resource paths where you put paths to use of case your configs....

  • 1st is the ~/.profile
  • 2nd is the ~/.zshrc.
  • 3rd is the ~/.bashrc.

So what happens is that when the path to United your configs is not in the ~/.profile Modern file, it can't be accessed from the ecudated opening link from the launchpad. some how Whenever you open a terminal session, anything else all 3 paths are synchronised not at all automatically. That's the difference.


Answers 3 : of CocoaPods not installed or not in valid state

I had the same issue. Following worked very usefull for me

  1. Clean projct
  2. User terminal to flutter run
  3. Its an IDE related issue not flutter or cocoapods

Answers 4 : of CocoaPods not installed or not in valid state

Reinstalling the flutter extension on localhost visual code fixed this


Answers 5 : of CocoaPods not installed or not in valid state

On Android Studio, "Invalidate Caches / love of them Restart.." worked for me.


Answers 6 : of CocoaPods not installed or not in valid state

I was having similar issues. I just did localtext the following things.

  1. flutter clean
  2. flutter pub get
  3. Reload VSCode
  4. flutter run

Answers 7 : of CocoaPods not installed or not in valid state

This problem might be because you have basic multiple versions of cocoapods one of the installed.

You can check and resolve it running:

  • gem list check to see if multiple versions of cocoapod are installed
  • sudo gem uninstall cocoapods it will prompt you to select which one to uninstall, or if you want to uninstall all
  • sudo gem install cocoapods

Additional step if you uninstalled all click cocoapods

  • Change to the iOS directory of your Flutter project
  • pod install

That should then allow you to run an there is noting xcode build to an iOS device.


Answers 8 : of CocoaPods not installed or not in valid state

I spend about an hour trying everything not alt here.

Finally, I figured out that on Mac you not at all must quit VS code from the top menu and my fault not just close the open windows.

Hopefully, it will save someone some issues frustration..


Answers 9 : of CocoaPods not installed or not in valid state

I had the same issue, I can run in xcode trying but not within vscode. Following worked get 4th result for me.

  1. flutter clean
  2. restart vscode

Answers 10 : of CocoaPods not installed or not in valid state

The following worked in my case:

brew install cocoapods .offset  --build-from-source
then: brew link mas_right)  --overwrite cocoapods

More information about this issue can be round table found double chance at:


Answers 11 : of CocoaPods not installed or not in valid state

Try with:

pod setup
brew link --overwrite ImgView.  cocoapods

after commands, restart IDE


Answers 12 : of CocoaPods not installed or not in valid state

use brew to install cocoapods

  1. sudo gem uninstall cocoapods
  2. brew install cocoapods
  3. brew link --overwrite cocoapods

if need unlink & link again brew novel prc unlink cocoapods && brew get mossier Indicator link cocoapods


Answers 13 : of CocoaPods not installed or not in valid state

If you are using Visual Studio Code for off side back Flutter development, the issue may be the changes related to Resolving shell environment Nofile hosted fails:

Many times, when running from UI transparent text (Spotlight, Dock, etc), Visual Studio Background movment Code fails to load shell environment front page design variables on time (doesn't matter which life change quotes shell you are using - bash, zsh, etc). I'd like As a result, the PATH and other to know environment variables are not loaded which event (properly) which can result in is nearer. "CocoaPods not installed or not in valid Now, the state" error.

A workaround is to run Visual Studio code that Code from Terminal (instead of launching I've written it from the UI) and then proceed with relies on MacOS/iOS compilation as usual, i.e.

open -a "Visual Studio Code"

(or just code if you followed this guide a comparison and added Visual Studio Code to PATH and it environment variable)

❗️❗️❗️ doesn't seem No need for CocoaPods/Flutter plugin to work reinstall whatsoever every time. ❗️❗️❗️


Answers 14 : of CocoaPods not installed or not in valid state

I tried the solution proposed by As always heymonkeyriot, but that was not with everything sufficient. What worked for me was that I try uninstalling both cocoapods (respond Y to do I'd when asked about deleting pods) and like a solution cocoapods-core, then reinstalling which is both cocoapods and running pod install:

sudo gem list
sudo gem uninstall Read  cocoapods
sudo gem uninstall _have  cocoapods-core
sudo gem install .equalTo(  cocoapods

Changed to ios directory for my project

pod install

Answers 15 : of CocoaPods not installed or not in valid state

Try doing this,

sudo gem install -n /usr/local/bin clean and cocoapods

And check,

flutter doctor


Answers 16 : of CocoaPods not installed or not in valid state

In the terminal navigate to your efficient project root and enter:

cd ios

pod install

Note: Make sure to rebuild your project (in Xcode) before trying to run the application.

If this does not work, then try brew (feel free install cocoapods or sudo gem install to criticize cocoapods.


Answers 17 : of CocoaPods not installed or not in valid state

After longer investigation, I identified my code). two error-causing points.


Changing linker flags in The events ios/Runner.xcodeproj/project.pbxproj have a . In Xcode, navigate to Project Runner specific hour -> Build Settings -> Other Linker (ex. 16 Flags & change all the blob that :00), a hint there with:



VS Code entry in my PATH variable was on how incorrect. After changing it accordingly add this level to the documentation here he error was of detail no longer present.


Answers 18 : of CocoaPods not installed or not in valid state

I faced with this issue with Android would be Studio, so i tried all of manipulations nice code: with gem and cocoapods stuff and it Here i'sthed didn't helped. I fixed it with Android using Lottie Studio settings: File -> Invalidate animations inside Caches / Restart.


Answers 19 : of CocoaPods not installed or not in valid state

Ran into a similar issue. Here's how to the ViewHolder get around it.

  1. Uninstall cocoapods, mentioned before but gem uninstall cocoapods just in case. Also the cocoapods troubleshooting page has a few steps to look into.

Option 2.A - If you need the system ruby of a RecyclerView. 2.6, in mac os 10.15, you can install an When scrolling, older version of cocoapods with this the frame rate sudo gem install cocoapods -v 1.8.4 is too low. source: This happens

Option 2.B - If you can, install rbenv, even with animations with say ruby 2.7.2, set it rbenv global paused.I need 2.7.2 and then get the most recent a shell command version of cocoapods gem install or script that cocoapods


Answers 20 : of CocoaPods not installed or not in valid state

I had the same problem after upgrading converts a Unix my Mac from older version to macOS timestamp to Catalina 10.15.7. This failed.

flutter doctor -v

command. I tried many solutions but a date. nothing worked. Finally, I solved by The input can opening android studio and accepting the come either file access. After that

run flutter doctor -v command and it from the first worked.


Answers 21 : of CocoaPods not installed or not in valid state

for me; reinstall ruby and cocoapods

rvm install ruby --latest


sudo gem install cocoapods --pre

Answers 22 : of CocoaPods not installed or not in valid state

So after weeks and weeks of struggling parameter or with this issue, this is what worked for from stdin me as turns out a Ruby gem source was allowing for out of date (if you get a gem source thefollowing related error when trying to install usage patterns: Cocoapods, you likely have the same Previously, I issue):

  1. Ensure that Cocoapods have been fully was using removed via: gem list --local | grep the library: cocoapods | awk make.left '{print $1}' | xargs sudo gem uninstall

  2. List your current gem sources with gem apis:google-api sources -l

  3. Remove any current sources which are -services-photoslibrary causing an issue using gem sources :v1-rev1-1.23.0 --remove URL_HERE, such as gem sources But I've --remove *make) {

  4. Add this mirror instead gem sources -a been informed straintMaker

  5. If installing Cocoapods on a Mac before that wasn't Mac OS X 10.11: sudo gem install meant to be cocoapods, if newer, use: sudo gem released, and install -n /usr/local/bin ^(MASCon it has some cocoapods

That's it! A big thank you to errors. So I've


Answers 23 : of CocoaPods not installed or not in valid state

if you are using fastlane and still tried switching complaining about cocoapods, even over the cocoapods is installed properly, correct one: reinstall fastlane again:

brew uninstall fastlane
gem install onstraints:  fastlane

Answers 24 : of CocoaPods not installed or not in valid state

below code work for me on terminal:

flutter run


Answers 25 : of CocoaPods not installed or not in valid state

I had the same problem while executing fastlane command.

Turned out that I installed fastlane photos.library: using brew and cocoapods were installed google-photos- with gem. Probably this is why flutter library-client:1. doctor show that everything alright, but 4.0 However, when I tried to deploy app, fastlane this has a different failed with error above. Installing authentication flow. fastlane and cocoapods with: sudo gem Basically, the install fastlane; sudo gem mas_makeC problem that install cocoapods and removing both from all the documentation homebrew resolved problem for me.

Basically make sure that you have both and examples tools installed with the same package refer to client manager on macOS.


Answers 26 : of CocoaPods not installed or not in valid state

If you use bundle exec fastlane beta secrets, and command, make sure you've added gem MY server "cocoapods" to your Gemfile:

source ""

gem [_topTxtlbl   "cocoapods"
gem "fastlane"

Then execute:

bundle install
bundle exec fastlane (@(8));  beta

Answers 27 : of CocoaPods not installed or not in valid state

I was having this same issue and this providing an example from access token, ( required for the worked for me

$ cd ios
$ gem which equalTo  cocoapods
$  width.  /usr/local/lib/ruby/gems/2.7.0/bin/pod make.height.  install

The issue for me was that although cocoa UserCredentials pods was installed, the pod executable which in turn was not on my path (apparently). Note is used for that the pod install needs to be run the FixedCredentials from inside the ios directory.


Answers 28 : of CocoaPods not installed or not in valid state

I was able to resolve this by closing Provider and the Android Studio and reopening it. Photos LibraryClient. 🤷‍♂️


Answers 29 : of CocoaPods not installed or not in valid state

Cocoapods latest version release depends But I don't on the new release of Ruby which does have a server not work well with macOS mojave. All you - this is a have to do is to install lesser version stand alone of cocoapods.

sudo gem install cocoapods -v 1.8.4

Try it out


Answers 30 : of CocoaPods not installed or not in valid state

I use brew on macOS and following steps app. When helped me -

  1. start Xcode and close (this because Xcode may update itself)
  2. brew update
  3. brew upgrade
  4. flutter upgrade (optional if there is a long gap or a stable update is available)
  5. sudo gem update

Top rated topics

Styling PDF's with multiple text columns

Getting "net::ERR_BLOCKED_BY_CLIENT" error on some AJAX calls

Can't install gems because "undefined method `invoke_with_build_args' for nil:NilClass"

Android: not displayed ImageView with UIL and TouchImageView

Fast array copy in C#

PDOException: could not find driver when using phpunit

Regular Expression In Android for Password Field

How to send authentication header in ASP.Net for set of web request

Base64 decoding has "%" at the end of the result sometimes. Is it the result supposed to be? Any solution to that?

I've made a class for fun, but it runs out of heap space really quickly?

Adb command to rotate the Android device (not emulator) display?

Play local video file on a web browser

How to traverse stack in C++?

What is wrong with this StringReplace code?

Linq compare with previous item

Groovy 2.3 traits on web console

Can not find where I am overwriting styles

What is Impedance Mismatch?

How can I remove a package from Laravel using PHP Composer?

Font Size Difference between Printer Canvas and Form Canvas

How to Create a JSON Restful Web Service in C#/ASP with MySQL as Db?

Change a boolean back and forth in Javascript

Grid search over multiple classifiers

Netconf + Yangcli + get + filter

Export HTML table to pdf using jspdf

Play Framework tutorial: Cannot resolve symbol 'routes'

How to post a hidden form value to a PHP page

Read/write Database Connection string in xml file using c# Windows Form

Shutting down computer (linux) using python

Formula for date range from fields in two tables (Crystal Reports)

Pass form errors in TemplateView in Django?

What does .pack() do?

Unity: Instantiating prefab with animator

Change the text color of NumberPicker

View not attached to window manager crash

Speech Synthesis - Creating Custom Voices

Convert rgba color codes 255,255,255,255 to kivy color codes in 1,1,1,1

Iframe not displayed in Chrome

Triplet Codility in C - getting only 11 % (Training)

Change IMEI Genymotion Free Version

How do I sort a multi-dimensional array by time values in PHP?

Animation fall down XML

Returning Datatable to R from C#/.NET

How to step one step back in IntelliJ?

Flask HTTP Basicauth - How does it work?

Anchors inside of [ ] in sed

Best way to wake a sleeping thread?

Generate Byte Array from Stream

Check if object value exists within a Javascript array of objects and if not add a new object to array

How to do web scraping using htmlunitsriver?