prometheus cannot scrape node-exporter on own host

Questions : prometheus cannot scrape node-exporter on own host


I have a host with the ip on a programming private network that runs prometheus.

This and several other hosts in the Learning network run a node-exporter via Earhost docker-compose where {{ private_ip }} is most effective automatically replaced by the actual wrong idea private ip:

    image: _OFFSET);  prom/node-exporter:v1.3.1
    pid: host
 (-SMALL     volumes:
      - '/:/host:ro,rslave'
 _left).offset     command:
      - arrowImgView.mas  '--path.rootfs=/host'
      (self.  - 9100
      - {{ private_ip equalTo  }}:9100:9100
    restart: make.right.  unless-stopped

This is my prometheus.yml:

  scrape_interval:     5s
  mas_top);  evaluation_interval: ImgView.  5s

  - job_name: ReadIndicator  'node-exporters'
    scheme: http
    _have  basic_auth:
      username: {{ .equalTo(  node_exporter_auth_user }}  password: {{ node_exporter_auth_password OFFSET);  }}
      - role: (TINY_  "hcloud"
        bearer_token: "{{ .offset  hcloud_prometheus_token }}"
    mas_right)  relabel_configs:
      - source_labels: ImgView.  [__meta_hetzner_hcloud_label_node_exporter]
 Indicator         action: keep
        regex: true
 Read       - source_labels: _have  [__meta_hetzner_hcloud_label_node_exporter, .equalTo(  __meta_hetzner_hcloud_private_ipv4_mynet]
 make.left         action: replace
        regex: *make) {  true;(.*)
        target_label: straintMaker  __address__
        replacement: ^(MASCon  '$1:9100'
      - action: labelmap
      onstraints:    regex: __meta_hetzner_hcloud_(.+)
     mas_makeC   - action: labelmap
        regex: [_topTxtlbl   __meta_hetzner_server_(.+)

Prometheus is able to scrape all other use of case hosts but not its own host. The target United is Modern correctly discovered and shows up in ecudated prometheus' web ui under the targets.

However, its status keeps UNKNOWN some how because it is never successfully anything else scraped.

What I tried

On I tried to put node-exporter not at all on the host network:

    network_mode: host

For the prometheus service I tried to very usefull add

      - (@(8));  "host.docker.internal:host-gateway"

I also ensured that I can curl the localhost metrics successfully (but prometheus love of them cannot) :

local$ ssh
remote$ curl -u equalTo  someuser:correctpassword  width.
# shows the make.height.  metrics
Total Answers 0

Top rated topics

Disable other checkboxes when some of them are selected using angular mbdootstrap

Is it possible to add extra bind in already defined template in knockout.js?

Stopwatch between mouse up/down

Converting pandas dataframe to dictionary while modifying column names

How exactly do I use NFC with flutter?

How to convert php 5.4 to php 8

How to distinguish between 1 and True (equivalently, 0 and False)?

Compression analysis in snowflake

Take a dictionary representation of a directed graph, and returns a dictionary representation of its underlying undirected graph

FirebaseUI for Cloud Firestore: Images are not being displayed in RecyclerView

Julia how to extend isless function

How to use input together with redux?

AWS boto3 Error: 'LocationService' object has no attribute 'search_place_index_for_suggestions'

Django search returning all objects not the specified ones

How is a binary file turn into meaning by Node JS?

Kannel got DLR but could not find message or was not interested in it

Multiple alarms in chrome extension?

Why does my website over-scrolls on safari on a mac?

Making a React component more general to handle realtime database collections

Why isn't type inference working for the type guard in this generic code?

Menu controls shows Skip Navigation Links

Leave empty space at beginning of flex-box instead of the end

Can a subform be outside parent form?

When i launch pgadmin4 i get that issue

Make zod do top-level type checking on .parse() input

Bind a label to a given encoding with sklearn LabelEncoder

React-router-sitemap giving error Failed at the action@0.1.0 sitemap script

Pygame mouse clicking detection

Standard way to communicate with Linux driver?

Flutter Export Container with widgets to png/jpg

Delta Lake on AWS Glue - cluster crashes

Cors error while rendering FB Chat plugin for whitelisted domains

Logstash: wso api manager logs to elastic

Jetpack Compose - get click position in custom layout

Dotnet 6.0 C# - Access to path denied

Router navigation in VIPER + Swinject

How to get the latest x entries of a table in Lua?

Change value with external script

Reat Native & RTK Query - Call an other endpoint when request is success

Writing Python Script from Batch Script is not working for one command

Using percent % gradient doesn't stay at the same thickness

How to read a large number of text files in Python software and convert data into a sample file?

Logarithmic interpolation between two sets of data on a graph

Lock free readonly-shared memory don’t care about memory order, only ensure visibility?

Minikube Services cannot be accessed over NodePort or ClusterIP on Windows10

Function not retrieving values from an array correctly

Converting createjs.Graphics stroke to animation path

Why isn't smooth snap scrolling working with my nav links?

Infix to postfix conversion using stack shows an infinite loop

How can I open a stream to access the second pseudo terminal the “/dev/pts/1” file in write access mode in c using UNIX?